1. オフィス24 グループ ホーム
  2. OWS Sプラン PHPバージョン7.2への切り替えのご案内

OWS Sプラン PHPバージョン7.2への切り替えのご案内

OWS Sプラン PHPバージョン7.2への切り替えのご案内

平素は弊社サービスをご利用いただきまして、誠にありがとうございます。

このたび、OWSのSプランにて提供しておりますWebコンテンツ作成に用いられるプログラミング言語のひとつPHPのバージョン5.6、7.0につきまして、

PHP公式のセキュリティサポートが2018年末をもって終了予定となっております。

つきましては2019年初め頃にご利用のサーバーのPHPバージョンを現在ご利用のPHPバージョンから7.2への切り替え実施を予定しております。

※PHPのご利用の有無に関わらずサーバーに備わった機能のためご案内しております。何とぞご理解を賜りますようお願い申し上げます。


PHPバージョン7.2への切り替え予定日時

2019年初め頃(日時未定)

※切り替え予定が確定しましたら別途ご案内させていただきます。
※PHPバージョン7.2へ切り替え実施後もPHPバージョン5.6、7.0に切り戻すことは可能ですが、サポート終了までにPHPバージョン7.2への切り替えをお願いいたします。

 

※PostgreSQLをご利用のプランに対するPHPバージョン7.2への切り替えにつきましては実施いたしませんが、PHPバージョン5.6提供終了までに切り替えをお願いいたします。


PHPバージョン7.2への切り替え作業について

2019年初め頃の切り替え実施前に、事前にお客さまにてPHPバージョン7.2への切り替えをお願いいたします。 PHPのバージョンを変更することによりスクリプトが正常に動作しなくなる可能性がございます。
PHPバージョン7.2切り替え前に事前にコンテンツが動作するかの確認をしていただくようお願い申し上げます。

データベースのPHP対応について

PHPバージョン7.2をご利用いただくにあたり、データベースの種類により、PHPバージョン7.2でのご利用ができません各データベースの対応につきましては下記をご確認ください

MySQL4 利用不可
PHP7.0以上のご利用ができません。
MySQL5.1以上にアップデートが必要となります。
MySQL5.1 利用可能 ※ただし下記パスワード警告表示は利用不可
サーバー管理画面のデータベース設定よりパスワード再設定の警告が表示されている場合、PHP7.0以上ではご利用できません。
パスワード再設定作業が必要となります。
PostgreSQL 利用不可
MySQL5.1以上へのデータベース移行が必要となります。
MySQL5.7 利用可能

データベースの移行作業やパスワード設定の詳細ににつきましては、下記のURLをご参照ください。

またこの機会にMySQL5.7へのバージョンアップのご検討をお願いいたします。

▽MySQL4から5.1への移行手順
https://help.gmocloud.com/app/answers/detail/a_id/2843/

▽MySQL5.1パスワード再設定
https://help.gmocloud.com/app/answers/detail/a_id/2745/p/8/#pw
※空白パスワード欄にご利用のデータベースのパスワード設定をお願いいたします。パスワードに誤りがあるとデータベース接続エラーとなります。

 

▽MySQL5.1からMySQL5.7へのデータ移行方法
https://help.gmocloud.com/app/answers/detail/a_id/3026/


PHPバージョン7.2切り替え方法

PHPのバージョンを切り替える機能につきましては、iCLUSTAシリーズのサーバー管理画面、CONTROL PANELにログインして、現在ご利用のPHPのバージョンからPHPバージョン7.2へ切り替えることが 可能となります。

※PHPバージョン7.2へ切り替え後もPHPバージョン5.6、7.0に切り戻すことは可能です。

▽PHP設定マニュアル
https://help.gmocloud.com/app/answers/detail/a_id/2964

ご提供サービスの安定運用に必要な対応のため、何とぞご理解を賜りますようお願い申し上げます。